You are just a click away from registering for the ACBLscore® for Beginners course. You will be charged $20 for the course through Discoverlink, the ACBL’s online education provider.

System Requirements

You need Mozilla Firefox, or Microsoft Internet Explorer 7.0 or higher. Click here for browser and plug-in requirements.

Register Now

Click on the link below or paste it into your browser.

https://lms.discoverlink.com/acbl

Click on the Order Courses button, and select your course. Click on the Search Now button, and click on the shopping cart to the right of the course name. Follow the instructions to complete your purchase. When you register, you will be emailed a User ID and Password. You then will return to the site to order the course.

Payments

You must make your payment by credit card at the Syberworks e-commerce site. The site is safe and secure.

Frequently Asked Questions

How long do I have to complete the course?

30 days. The start and end dates will be noted on your order form.

How do I download ACBLscore® to practice?

Versions for DOS and Windows are available for download.

How do I change my password?

When you are logged into the course, you can go to My Account, then Contact Information to change your password to one of your choice.

Where can I go for help?

Questions about registration and ordering
Questions about ACBLscore
General questions about the ACBL

What is the ACBL Learning Center?

More information and explanations of various Learning Center features.

What browser do I need?

You need Mozilla Firefox, or Microsoft Internet Explorer 7.0 or higher.

What browser plug-ins do I need?

You will need to have the Sun Java plug-in enabled for your (Internet) browser. You can check this by going to the Tools option of your Microsoft Internet Explorer browser, for example, and selecting advanced options.

If the Sun Java plug-in is available for your use, you will be able to check that box in the list of options. If it is already checked, your browser is already using the Sun Java plug-in.

If there is no listing for this plug-in, you may download the plug in. Click Get SUN Java to download the plug-in.

Some of the links in this course open up printable documents in Adobe pdf format.

You must have the Adobe Acrobat reader version 8.0 or higher. Although lower versions of the Adobe Acrobat reader will work, the documents will appear less sharp and readable. Here is a link to the Adobe website from which you can download the most up to date Adobe Acrobat reader: Get Adobe Reader You must have the flash plug-in installed in your browser. The flashplayer enables you to view video and audio movies throughout the courses. Click Get Flashplayer

How can I get a new browser?

To download the most recent version of Firefox, use the browser you currently have installed to go to www.mozilla.com. Once you see the Mozilla home page, download a new copy of FireFox.

To download the most recent version of Microsoft Internet Explorer, go to www.microsoft.com and follow the links to download a new copy of Internet Explorer.

Both the Mozilla and Microsoft download areas include instructions on how to install the browser after you finish downloading it. You should print these instructions, so you can refer to them during the installation process.